星月设计网 首页 技术分享 discuz!技术 查看内容

关于Discuz!建站选择DZ X3.3 X3.2 F1.0 GBK UTF8 PHP5.4 7.0版本等建站运营选择指导

2018-12-27 21:23| 发布者: admin| 查看: 917| 评论: 0

摘要: Discuz!是一套通用的社区论坛软件系统,草根站长可以很轻松上手的搭建出来一个论坛、门户、地方网站等网站出来, --------------------------------------------------------------------------------------------- ...
Discuz!是一套通用的社区论坛软件系统,草根站长可以很轻松上手的搭建出来一个论坛、门户、地方网站等网站出来,
----------------------------------------------------------------------------------------------------
此帖有效期至 2017年,截至2018.09.17,虽然DZ X3.4 N多小bug,还是推荐站长升级到此版本。

php版本选择5.6,mysql 5.6,环境选择 nginx, 以下内容仅为2017年至以前参考。。。
----------------------------------------------------------------------------------------------------
如果是Discuz!X3.4 程序,最佳运行环境php7.1.x[部分插件并不支持php7.x,请注意!!!],mysql 5.6 , utf8编码 ,InnoDB数据库引擎。(2018.12.06建议)

Discuz!程序版本选择:
站长在刚选用Discuz!建站的时候对目前市面流行的Discuz! X3.4、Discuz!X3.3、Discuz!X3.2、Discuz!F1.0、Discuz!+ SlimBBS Team等官方的、民审作者的、爱好者的众多版本,其中Discuz!X3.2 和 Discuz!F1.0 在站长的选择和使用中最常见,
不推荐站长选择安装Discuz!F1.0 ,如果建站运营请选择 Discuz!X3.2 ,支持https(ssl)建议选择 Discuz! X3.4:
Discuz!F1.0 是应用中心民审、作者爱好者合作基于 Discuz!官方Discuz!X3.2、Discuz!X3.3、Discuz! X3.4版本之上推出的基于PHP 7.1、MySQL 5.8最新环境适配、精简的Discuz!论坛程序,目前对Discuz!F1.0 的支持应用DZ插件、DZ模板都相对较少,很多DZ插件、DZ模板对Discuz!F1.0 的支持性也较少,根据目前站长普遍的反馈而言,使用Discuz!F1.0 建站的站长遇到的问题往往比较繁琐,且目前民审、开发作者、爱好者出品的Discuz!F1.0 版本已经处于停摆之中,站长最终都选择了Discuz!F1.0 降级为 Discuz!X3.2、Discuz!X3.3、Discuz! X3.4。

Discuz!插件模板版本选择:
很多站长也问到有些老的DZ插件、DZ模板写的适合Discuz!X3、Discuz!X3.1,是否可以使用在Discuz!X3.2上面,
针对这个问题做个统一的普及:
X3.2 是X3版本以来的最终修订版   X3 X3.1 X3.2 X3.3 X3.4 都是X3版本  .1 .2表示修订版本号,Discuz!X3.2 是Discuz!X3系列最终稳定版本,Discuz! X3.4是DZ仅次于官方的开发维护版本。

所以
适合Discuz!X3、X3.1版本的DZ插件、DZ模板是适合并兼容 Discuz!X3.2站点使用的,请站长放心安装使用。但适用于X3.2版本的应用90%以上是不兼容Discuz! X3.4和php 7.x的,请格外注意!!!

X3.2 的站长在未完全确认自己已分享的应用是否兼容版 PHP7 前,我们不鼓励您升级到 X3.4 并将您的服务器 PHP 环境升级到 PHP7.X,除非您继续在 PHP5 下使用。

总结: 如果网站安装使用有很多必不可少的插件和模板,建议稳定在 Discuz! X3.2,至多php 5.6环境,不要升级到 Discuz! X3.4 PHP 7.X 环境,切莫一味追求最新程序
          ※ 如果是全新站,对插件、模板依赖度不大,完全建议安全全新 Discuz! X3.4 ,且环境建议 安装选择 PHP 7.X,环境最好支持php7.1,且最好直接上 https(ssl)。 [2018.12.06更新建议]

  • 由于 X3.2、X3.3 已停更,X3.4 漏洞和相关修补同样适用于 X3.2、X3.3 版本,请随时关注更新列表,您可进行手动修补,让自己的站点时随刻保持最安全的状态 [2018.12.06更新]

Discuz!语言编码选择:
关于选择Discuz!程序论坛建站编码问题,如果你做的是国内论坛,建议首选SC_GBK编码论坛,基本上80%以上的插件、模板都对GBK论坛编码支持性良好,否则在大多数情况,你都必须转码才能正常使用站内分享的插件、模板,当然港、澳、台湾等站长可以选择 TC_BIG5 繁体中文编码,也有海外站长那就选择 SC_UTF8 编码也行。
Discuz!建站环境选择:
关于建站搭建环境问题选择:Discuz!官方推荐最佳兼容环境 php-5.2.x + mysql5.1.x 版本,若有更高性能需求可以安装php-5.3.x+mysql5.6,至多兼容php-5.4.x/5.6.x+mysql5.8(注意:PHP 5.4环境仅推荐应用到UTF8编码论坛)【mysql版本越高越耗费内存,推荐至多安装mysql 5.6版本】,仅 Discuz!F1.0 版本相对兼容PHP 7.x 或 更高版本[目前PHP 7运行速度相对比以往版本有较高的速度和效率提升,但大部分源码程序都相对不太兼容PHP 7.x环境],但随之连带不兼容问题更多,所以是不建议新手站长(GBK编码论坛)选择安装 Discuz!F1.0 ,或选用最新的PHP7.x支持的Discuz! X3.4程序。

综上所述:如果是GBK编码论坛尽量选择php-5.3.x+mysql5.6 组合,当然,安装的插件应用不多的话,也是可以直接安装PHP 5.6.x+mysql 5.6UTF8编码论坛尽量选择php-5.4.x/5.6.x+mysql5.6组合,部分zend加密插件仅适用于php5.2环境的论坛,那么只能选择 php-5.2.x + mysql5.6 组合,或最新的Discuz! X3.4是支持PHP7.x的。

关于服务器环境 LAMP 好还是 LNMP 哪个好?
优先推荐:LNMP 环境,一键环境推荐 Amh,因为对php 7.x、https(ssl)部署非常方便快捷。

相关阅读

编辑推荐

更多>

社区精选

搜索
返回顶部